Публикации

Форумы

Не загружаются изображения штатным порядком
 

Не загружаются изображения штатным порядком

1 2  
Модераторы: Патрик, net1313, Predator, Perfecthus, Kapman
Автор Добавил
Offline Overkiller
10.04.17 - 14:12
Сообщений: 8
При попытке прикрепления изображения к сообщению на форуме, сообщение появляется, а вот изображения нет. Никаких ошибок не вылезает, просто оно не появляется, ни в превью, ни в сообщении, ни в картинкохранилище на сайте. e107 Version 1.0.4 Проверял в настройках в админке - все нормально, изменял размеры вложений, включал-выключал загрузку - 0 эмоций.
Пробовал мучительно мигрировать на версию 2.1.х - там та же ерунда. Откатился обратно на версию 1.0.4. Переустанавливал с0 и обновлял движок сайта - не помогло.
Помогает только очистка базы, но это не вариант для меня.
Где искать проблему? Я в базе не разбираюсь, а за меня никто не сделает
Вернуться наверх
Популярность сообщения: 0
Рекламный блок
VPS
Наверх

Offline Predator
10.04.17 - 14:24
Predator


Сообщений: 4052
Права на каталоги, куда загружаются изображения, смотрел?


Я не матерюсь, а всего лишь употребляю ненормативную лексику в целях более полного и лаконичного выражения своих эмоций.
Вернуться наверх
Популярность сообщения: 0
 
Offline Overkiller
10.04.17 - 14:46
Сообщений: 8
Да, стоит 755 на e107_files/public (и на ту и на другую)
Менял на 777 и 644. В последнем случае ругается что папка не записываемая.
Вернуться наверх
Популярность сообщения: 0
 
Offline Predator
10.04.17 - 14:55
Predator


Сообщений: 4052
Может, что-то в настройках движка не включено, в админпанели.

10.04.17 14:55:54  Добавлено автором к сообщению...

Да и о какой версии движка вообще речь?


Я не матерюсь, а всего лишь употребляю ненормативную лексику в целях более полного и лаконичного выражения своих эмоций.
Вернуться наверх
Популярность сообщения: 0
 
Offline Overkiller
10.04.17 - 15:26
Сообщений: 8
e107 Version 1.0.4
Ставил с 0 и апгрейдил с более старой - безрезультатно.
Апгрейд до 2.х ничего не дал - как только цепляет базу - сразу прекращает вставлять изображения.
На данный момент стоит с нуля 1.0.4 интерфейс английский.

В админпанель сходил еще раз:
в настройках форма
1.Enable file / image attachments ENABLED

2.Maximum width of uploaded image стоит по-умолчанию 1500k обнулял - не помогает
Leave blank to disable auto resizing of images

3. Allow users to upload file or image with their forum post, click here to set max file size, allowed types etc там стоит:
Uploads Enabled? - yes

Storage type - Flatfile

Maximum file size - 5M

Maximum upload size in bytes - leave blank to use settings from php.ini (upload_max_filesize = 100M, post_max_size = 20M ) менял - не помогло

Allowed file types
For security reasons allowed file types has been moved out of the database into a flatfile located in your admin directory. To use, rename the file e107_admin/filetypes_.php to e107_admin/filetypes.php and add a comma delimited list of file type extensions to it. You should not allow the upload of .html, .txt, etc., as an attacker may upload a file of this type which includes malicious javascript. You should also, of course, not allow the upload of .php files or any other type of executable script. zip, gz, jpg, jpeg, png, gif

в файл залезал, проверял, сам файл заменял другой версией и обратно - не помогло атрибуты этого файла 644

Permission - members


ps Вспомнил, почему не остался на версии 2.0 - для нормальной конвертации базы под новую версию пришлось менять php сервер - нужна была более новая версия. Но и после конвертации большая часть сообщений форума пропала. А ковыряться вручную в базе чтобы что-то поправить не умею

Вернуться наверх
Популярность сообщения: 0
 
Offline Predator
10.04.17 - 15:28
Predator


Сообщений: 4052
– Цитата: 
как только цепляет базу - сразу прекращает вставлять изображения.
Хмм... Попробуй, восстановление базы сделать в phpMyAdmin.


Я не матерюсь, а всего лишь употребляю ненормативную лексику в целях более полного и лаконичного выражения своих эмоций.
Вернуться наверх
Популярность сообщения: 0
 
Offline Overkiller
10.04.17 - 15:40
Сообщений: 8
Базу чекал через админпанель. Оптимизировал. Проверил на ошибки и оптимизировал через phpMyAdmin - безрезультатно.
К сожалению, проблема появилась очень давно - более 2 лет назад и если я подставляю старую - езще рабочую резервную копию, то она слишком стара. А в актуальных присутствует ошибка. Резервых копий (без этой ошибки) одна или две, обе очень старые.
Вернуться наверх
Популярность сообщения: 0
 
Offline Predator
10.04.17 - 17:15
Predator


Сообщений: 4052
Я писал не об «оптимизации», а об «восстановлении» БД - это, разные вещи.


Я не матерюсь, а всего лишь употребляю ненормативную лексику в целях более полного и лаконичного выражения своих эмоций.
Вернуться наверх
Популярность сообщения: 0
 
Offline Overkiller
10.04.17 - 17:28
Сообщений: 8
Сделал восстановление через phpMyAdmin - не помогло
Вернуться наверх
Популярность сообщения: 0
 
Offline Predator
10.04.17 - 17:34
Predator


Сообщений: 4052
Уже и не знаю, что тебе подсказать, да и версию 1.х никогда не пользовал.


Я не матерюсь, а всего лишь употребляю ненормативную лексику в целях более полного и лаконичного выражения своих эмоций.
Вернуться наверх
Популярность сообщения: 0
 
1 2  
Не загружаются изображения штатным порядком

Перейти:  Вернуться наверх