Новость: : Обновление 0.8 - грядущие изменения
(Категория: e107)
Добавил Metaller
01 Июль 2009 - 11:39

В то время, как версия 0.8 обретает форму, команда разработчиков решила рассказать о значительных технических изменениях, запланированных на релиз 0.8. Эти изменения могут повлиять на сервер или содержимое, так что можете начинать готовится прямо сейчас.

PHP 5.x будет минимально поддерживаемой версией - в настоящее время очень мало пользователей не имеет возможности использовать версию PHP5 и это число уменьшается. PHP4 уже более года не поддерживается авторами и поэтому разработчики е107 не видят более смысла писать на ней. Это потребует убрать некоторые константы в коде и даст больше возможностей для интеграции сторонних приложений.

Все данные будут в UTF-8, доступ к БД так же будет осуществляться на UTF-8. Многие сайты уже используют эту кодировку, однако будут предоставлены инструменты для переноса данных в 0.8.

Двоичные данные больше не будут храниться в БД, в любом случае этим почти не пользовались.В 0.8 все закачки/загрузки будут храниться в виде файлов.

Минимальной версией MySQL будет 4.1

Изложенные изменения касаются сервера и БД. Другие интересные изменения и новинки - на странице в вики.

Ну и как всегда - ничего о сроках выхода 0.8. В любом случае, хоть какая-то новость за прошедшие полгода.


Источник этой новости e107 Клуб
( http://www.e107club.ru/news.php?extend.145 )